Release 190 - Report issue here


#101

No. Like I said, the Atlas smart stack DOES NOT CONTAIN the Vulpto atlas. I am not sure how I can be clearer. The smart stack is a complete smart stack of 9 EMPTY atlases. The vulpto atlas is in a completely different inventory slot. Thanks, but I know how smart stacks work. I was reporting a bug, not asking for help.


#102

Okay, I can see you’re upset about my trying to help. In the future, I will abstain from trying.


#103

It shows that you have the materials to be able to craft 2 of the recipes, but as is shown you can’t craft in sanctum… however you do still have the items needed to be able to craft the recipes, which is what that indicator shows. The information about whether you can at this moment craft the item is always on that craft button, the same happens when your inventory is full.


#104

I am not upset. I am trying to explain that I provided the exact steps for reproduction, with a clear indication that the vulpto atlas was not in the stack (since I never said add it to the stack). I also wanted to let you know that people who report bugs with detailed steps, are not nincompoops, and actually have an idea of what they are taking about.

Instead of abstaining from trying to help, perhaps you should try to analyze whether the person actually needs help first. Unsolicited help, can make people think that you think they are an idiot, especially when you start your response with ‘thats just how it works.’ Try not to assume that every person just does not know how the game works. Anyone who has played the game for more than an hour knows that smartstacks show the icon of the first element in the stack. I indicated in the message right before the one you responded to that I was starting a second character… ergo, I played a first character already…

All I am saying, is read, don’t assume. Help where you can, just don’s assume everyone is a noob or everyone is an idiot.


#105

guess Ill drop it. the community seems to think it is not a bug. w/e


#106

I never said you were an idiot, or even remotely implied it. I followed up questions for clarity, even. I read what you wrote, and from what I gathered, I thought I found a potential solution to your apparent problem. Now, I don’t want to participate in what appears to be a hostile discourse, so instead of continuing this tone of conversation I will bow out. Thanks for explaining your stance on the issue.


#107

also, thanks for pointing out a valid reason, not just saying ‘that is how it works’. when i originally posted the bug, i somehow missed the message that says you cannot craft in the sanctum. you pointing that out, in a way that is not just simply ‘that is how it works’ was the right approach to make me re-read it and see that it does in fact tell you that. seriously, thanks.


#108

dude… seriously right now? “that is just how it works” is pretty much the equivalent of ‘you just dont know how things work’. on top of that, these two steps CLEARLY show that the vulpto atlas is NOT in the smart stack

  • fetch the atlas smart stack from the workbench (while still equipping the imprinted one)
  • notice that the the smart stack icon now shows a map of Vulpto…

you grab the smart stack from the work bench (the one you just created) and you put it into your inventory. the instantly the icon shows a vulpto icon… it is very very clear. if you read it, instead of assuming that your unsolicited help was the answer, then you would have realized that the smart stack did not have the vulpto one in it. just read man… read.


#109

Fog of war on atlases are not updating, at least not as you walk. I am on Berlyn, walking into ‘the void’ and when i bring up my atlas of Berlyn (which is equipped in my right hand as I run), I can see that it shows me in the middle of a fog-of-war cloud… wouldn’t it be better if it showed me that I have walked into this section of the cloud?


#110

It’s based on discoverable regions, so will only uncover when you find one of the 50 named points of a planet.


#111

Chill out, mate. He wasn’t trying to be rude, he misread/misunderstood what you said in the bug report, and he tried to help you with your problem to the best of his abilities (even though the problem at hand wasn’t what he thought it was). Nobody here’s assuming you’re an idiot, so try not to be so self-conscious and politely tell him that he misread.


#112

no. im sorry but he definitely approached it wrong… and telling me that im wrong wont change that.people who assume that a person does not know what is going on, and especially those who blatantly say ‘that is just how it works’ as the OPENER for their response, NEED to be confronted, and correct. otherwise, THEY will denture people with actual bugs to report from reporting them. even worse, if they go unchecked, then a decision maker who reads the post might think that their response was the valid correct answer. i certainly dont want a dev thinking that a response from a person who did not even read the original report is in fact the solution to the problem… when it is just assuming that i dont know how to play the game.

as for being self conscious… that is your opinion. the response was very clearly rude. it assumed that the poster did not know how the smart stacks work… a problem that could have been avoided by reading the OP. if him “solving” a problem that was not reported equates to me being self-conscious… then so be it.

you are right i definitely assumed that he was calling me an idiot… but perhaps he should have at least attempted to phrase his response like he was talking to person who 1) has played the game and 2) has the cognizance to report a bug they found. all im asking for here is to not assume that every person who is reporting a bug here is just an idiot who does not know how the game works…i mean look at @willcrutchley and his response… he didnt assume that the poster didnt know how to play. he clearly wrote why the situation was the way it was, and clearly wrote that there is a message saying as much. he didnt approach it with ‘that is just how it works’… he explained the solution, and explained that there was already an indicator for it…

so again no. if a person is not paying attention or is out of line… at least against my reports, im gunna call them out, regardless of your feelings or how i look to you. i want my bug to be taken seriously like all the others, and most of all i dont want it to be overlooked because a person answered an almost unrelated question. im gunna say something, not sit back and take a lashing


#113

Yes, you are right. Correcting someone who was incorrectly judging your comment makes sense, and I’m not saying you were wrong in doing that. However, you could have done so in a more polite manner. Assuming in your comment that “that is just how it works” means “you just don’t know how things work” implies that he was being rude to you. Assuming that he did not read the OP implies that he’s just dumb. Now, I can understand your concern that a dev would overlook your report because a response to it was “the solution to the problem”, but once again, the discussion can be settled politely.

Sure, the response assumed that the poster did not know how the smart stacks work, but he wasn’t assuming it because he thought you were stupid, but because it sounded to him like a problem he knew how to handle. I called you self-conscious because your reaction to him trying to help felt extremely defensive, and that you were assuming he called you an idiot. I’m sorry if that seemed rude to you.

Again, I agree that he could have phrased the comment differently, but it’s not uncommon that a “bug” just turns out to be OP’s own mistake. He didn’t know if you were a newcomer or veteran and because your comment sounded like a simple issue he assumed you were a newcomer who thought they stumbled upon a bug.

By all means, call people out on their mistakes. Just don’t get aggressive with people or put words in their mouth. You won’t be taken seriously by doing that, you’ll just look rude. I hope the both of you can apologize, or at least be on good terms with each other in the future, and keep the forums a friendly place as it’s supposed to be.


#114

So I’m going to say a few things here. And I’ve thought for the past four hours about the best way to put my words down so I don’t come off in the same condescending tone that you have towards someone who literally tried to help you:

First, I followed your “bug report” step by step and was unable to recreate your identified bug. So there is some piece of information that you are not providing us in order to recreate it. Maybe it’s how you transferred your blank atlases from the workbench to your inventory, because “fetch” isn’t a term that is really specific (although, you’ve been very quick to point out the specificity with which others use words).

Secondly, before you start to accuse other people of things that were never written (i.e., calling you an idiot) why don’t you take a step back and realize that when people write or say something how it is interpreted is solely up to the person on the receiving end. The fact that you chose to interpret @Chivlet’s advice as some sort of demeaning statement is all on you, bud.

Thirdly, Chivlet has a significant amount of posts on these forums; credibility built up in the game; credibility built up on the Discord channel, and not once has anyone ever accused him of being rude. If you actually read anything he wrote you would realize that Chivlet’s command of the English language, let alone language in general, is far greater than most people will ever achieve in their lives. So I’m pretty sure he “read your original OP.”

Fourthly, WRITING THINGS IN CAPITALS DOESN’T EMPHASIZE ANYTHING FURTHER IT JUST MAKES YOU LOOK MORE LIKE A FOOL.

Finally, the developers read everything posted in this forum line by line. The fact that you are making assumptions about their methodology for confirmation of a resolution to a bug is strictly that: an assumption, which as you know makes you look like an … And, please don’t bring in terms like “lashing” into a verbal argument. I would hope that your ability to converse with an adult (which Chivlet is) is beyond the use of slavery-related terms. In fact, his follow-up reply was quite elegant and understated. So next time, don’t waste everyone’s time with your ridiculous posts about how your feelings are hurt because someone tried to offer you a concise response that used too much brevity for your liking. Next time you could have responded with, “yeah, the smart stack consisted of 9 entirely knew atlases and the Vulpto one was second,” because, if you played this game as much as some of us you would know that there are instances when “fetching a smart stack” will sometimes break it up and apply it to the one that already exists in your inventory and create a second smart stack with the overflow items.


#115

This is a bug thread where people post problems and not get in arguments… Please move the discussion everywhere and the posts.


#116

ATTENTION

ANY FURTHER COMMENTS THAT ARE NOT A DIRECT BUG REPORT WILL BE DELETED WITHOUT FURTHER WARNING.

That is all.


#117

thanks. this helps


#118

also… since this will be deleted anyways… i guess im just not going to report any more bugs i find. thanks for the support community… big props…


#119

Please do continue to report bugs.

The atlas bug I did reproduce (I think the missing step you didnt mention was to move the smart stack of empty atlases onto the same slot with the vulpto atlas that is currently equipped so that they swap in the inventory). Funnily enough, when you move that smart stack elsewhere it goes blank again, and then putting it back in that slot and it shows the map again! so definitely a bug in the GUI. Breaking it out into 2 smart stacks and it stops happening… but then put it into a slot which has ever had that vulpto slot and it starts happening again! Its not a problem with the Items themselves though, as restarting the client does clear out the weird data, so is purely within the gui.

– edit: and fixed locally now :slight_smile: thank you @loushou!


#120

This is the issue we had when we were doing our vertical build. I definitely think that they should reevaluate the chunk mesh limits with the new engines.