Release 192 - Report issues here


#364

Almost exactly, have screenshots available with coordinates screenshotted on them. It a set of sceenshot, before, and what happend when I step forwards to a lower step. Can send the screenshots to you if you like.

Anyways, the scenario was as following: just dig a down in a stair pattern, suddenly you would sink half into a block and after that you end up in some kind of void…

Result:


#365

Finally figured out why shift+clicking sometimes works and sometimes doesn’t. Right shift+click does not, left shift+click does.


#366

Maybe 3 or 4 times over the past few months. Other times it has happened I’ve been running around picking up loot. I think it has only happened during hunts though.


#367

[quote=“vdragon, post:360, topic:13212, full:true”]

Were you encountering any kind of lag / latency issues at the time?

None at all. Everything was perfect other than the disappearing body.

It sounds quite similar to the issue reported by @Hashmalash from post #129. Do you remember the world and location where this occurred?

I was on Therka near my homes. I’ll get some approximate locations of where I was later. Off to go visit dentist now. Trust me, Boundless is more fun than dentists. :rofl:


#368

Using the gold grapple I’m getting stuck inside the blocks that I pull towards quite a lot. I think this is also the cause of a lot of teleports to surface from caves. Here’s a location where it just happened:


#369

@NL-Tim It has happened all across the universe. It’s happened when traveling through the Portal Seekers hub. It’s happened when just exploring Berlyn. There doesn’t seem to be any kind of pattern to when the crashes occur.

I was able to just RUN through the portal and make it through ANOTHER portal before the game crashed. Once I logged back in, I was back on Berlyn and now my game is fine…Super strange.


#370

Another freeze (this time on unstable connection), game doesn’t respond to Alt+Printscreeen either this time:

EDIT: About 2GB of ram usage, even terminating it from task manager took long…


#371

Thank you… yeah I just want it looked at ASAP. The changes I was looking to make was related to where plots were put and how Xaldafax, Merlyn, ShadowFax plot areas connect. I have a vacation coming up late this week and wanted to use that time to revamp some of the area. I don’t have much other time to play so this time is important to me.

If I make my changes I have a feeling it will affect how your code sees the settlement and then you will not be able to tell the real problem I am facing right now with how the plots somehow see things wrong. So I hope it can be looked like soon.

As for the other issue with the settlement beside me, below you will find the picture. Stuff on left is mine, stuff on right is theirs. We have 2 plots between us. If that is not enough space just let us know but I cannot find an official statement saying that there needs to be 3 plots between each settlement or if something else is happening with your code.


#372

I was mining at depth of 1 to 50 alt on Andooween I got stuck on edge of block and got sent to the surface 4 times kind of annoying . :slight_smile:


#373

@vdragon come on - you know my warped sense of humor by now surely :stuck_out_tongue: just it rubs the wrong way sometimes so i was trying (and failing?) to be toung in cheek :stuck_out_tongue: but thank you :slight_smile:

and as for the other blocks - as i say the fix i found was to dig around the pitfall bug and that fixes it… however as you can see in the video… if you replace the other blocks and touch the pitfall block again you will fall through once more


#374

I’ll add your comments to the database.

We’ve pushed a hotfix for this, so let us know if it’s working okay or if you ended up hitting the issue again.

Definitely send the screenshots with the coordinates so that I can take a look. I suspect it could probably occur anywhere in game, but at the same time it would be good to get examples of specific locations if the issue is likely to crop up more often within these areas.

Is this in reference to the earlier aforementioned issue about placing items into the radial display slots with the Inventory GUI where there appear to swap around, or is it something else?

Do you remember running over any uneven blocks?

Was it the first time you’ve seen the issue occur? I’ve not seen this myself.

Can you show a screenshot of the blocks you’re getting stuck inside? I can’t reproduce the issue you’re experiencing.

If you get the issue again, open the Latency Graph when the performance starts getting worse.

I had a look at the area highlighted in game and it does show that there are no plots in between. @james and @lucadeltodecso can probably explain what’s going on here.

Do you remember the location?

Parts of that area have beacon plots, so I was a little restricted on what blocks can be mined. I still cannot get the issue to occur, but it’s all on the video provided, which is enough to show that the problem is apparent.


#375

The time I recorded I was just jumping into the tower we build during the hunt when it happened. Other times I was running around grass with slopes, I"m not sure exactly when it started in previous cases (if it was when I hit a slope or what).


#376

If you open your inventory and Shift+Click it normally moves items to your quick slots. This works with Left Shift but never with Right Shift. Same goes for inventory -> stash, inventory -> shop stand, etc.


#377

The issue is the game totally freezing (as in the countown stays on 30, the game becomes non-responsive and even ignores OS commands like Ctrl+Alt+Delete, printscreen, etc.). This seems related to latency since I have had a spikes that lead to complete game freezes.

EDIT: And again. Got a lag spike or two and my client froze in the shop stand UI with an item suspended mid-drag.

Game was sitting at 2GB memory usage again vs its 1.2GB when running normally.


#378

I’m still getting strange Radial display behaviour…
I was digging around under my floor when I placed a smart stack of grapples into the bottom right slot and then the selector pointed at the empty top slot rather than the bottom where I just put the grapples.
ok now I just got another weird object movement while trying to reproduce the bug…
Here’s a detailed rundown:
I was just using an emerald spanner earlier (equipped in right hand left slot)
I opened my storage and moved the spanner into storage (while it was still equipped in my hand and I saw it disappear)
so now the right radial arrow is gone, which would be expected.
This is what my inventory looks like at this point, before the strange behaviour:

Now I’m not sure if there was anything different between the first time or when I was reproducing, I tried to do everything exactly the same…

anyways, the second time, I took the smart stack of grapples from within my inventory and placed it in the bottom middle right hand slot but this time the grapples went into the top middle slot instead and the radial arrow pointed up again.
(I am now typing this as I’m testing :P)

Third test: (ok this one was surprising)
equipped emerald to left middle slot on right hand side
opened storage, took emerald spanner (still equipped) and placed it in storage
opened inventory, took smart stack of grapples and placed them in bottom middle of right hand…
and it stayed there. the arrow also pointed to it.

sooo. it seems to be random! yay :disappointed:


#379

Yes it was around here 1,508n 2,242e alt 4 but I was moving so it was several other areas that it happened and at deferent depths I was mining white gleam at higher alt did same thing put me on top of floating island I was in and it seems to be every where that it happens I have had it happen on the surface of other planets where it will shoot you in to the air.


#380

So, since the hotfix I’m no longer getting any crashes, but I’m having weird behavior with maps. I was given a completed atlas by another player and when he hands it to me, I see something strange. I’ll let the screenshots do the talking. See screenshots for the complete atlas in another player’s hands and what I see.


#381

I’ve sent the zipped screenshots to the general Turbulenz support address (with attn. to vdragon).


#382

In Response To:

Notice that in the last picture that it appears that the graphic of the Diamond Torch is superimposed over the top of the Regular Torch. The Diamond Torch does not have Flames coming out of it. Also, that the light that the torches give off is more attune to the Regular Torch than the Diamond Torch.


#383

Hmm, slopes. If you happen to reproduce it fairly consistent in a specific area, let us know the location so that we can take a look.

As it stands, Left Shift+Left Mouse Button click places items into your left hand, and Left Shift+Right Mouse Button places them into your right hand. Certainly, if Left Shift carries out these functions then it would make sense that the Right Shift key should also perform a similar function, so I’ll add your input to the database.

Was it only occurring around your shop area, or anywhere in game?

I couldn’t reproduce this, but we have fixed some possibly related bugs, so these may rectify the problem.

From going to the location specified, it looks like you came across mantle at the very bottom. I wasn’t able to reproduce the issue exactly at that location, but I’ll add your report to the database anyway.

What item was added to the atlas at the time and what are the coordinates of the area you and the other player were standing at the time when the atlas was held on screen?

Thanks. There’s quite a lot of screenshots, certainly more than expected. I’ve taken a select few and added them to the bug database.

Thanks for the screenshot and the additional information. It does look like the Diamond Torch had adopted the particular effect’s from the standard Torch, so I’ll add this to the bug database.