Testing 187 - Report issues here

(I performed a skill reset to get my extra 300 skill points and to slowly introduce myself to the new recipes.)

I can craft “Fresh Vital Essence” with just “Basic Crafting Recipes” learned, even though it says i need “Common Item Recipes” in the tooltip.

I updated the original post to express the eating. Also as far as bomb mastery goes. What I didn’t know until a dev spawned some silver bombs in, is that copper bombs do not use the mastery or have bonuses from mastery. The description on the silver bombs work like that of higher level tools. So having a higher mastery unlocks higher %'s off the higher tier bombs. I didn’t see that in the update for say so though the bomb mastery was broke.
However Control skill seemed to do nothing, so maybe an explanation of how that helps would be nice, so we don’t assume its broken. In fact a lot of what I tested could just be misunderstandings of what you guys actually designed.

OK. I have noticed that you can put a different material in it to reattune it. I thought that that was maybe a way to remove the material.

EDIT: it appears that an atlas can only be reattuned to a new material until you discover a new region. Once a new region is discovered, it locks in that material for that Atlas. I don’t believe this is a bug. In fact I think it’s a great feature. One question becomes this: what happens once you have discovered all of the regions? Can an atlas thereafter be continuously reattuned?

1 Like

One other thing: I noticed from the colors of the Power coils that they probably should require different compact gems to craft them, however all of them currently require compact diamond. Either diamonds are going to be a very important resource in the future, or this is a bug and it should be the gem matching the color.

Could a developer please confirm that these recipes are incorrect? Otherwise, I am going on a serious Diamond run once I get back to the live server. :diamond_shape_with_a_dot_inside:

1 Like

Ah ok cool - that didn’t work for me last night. I must have done something wrong :wink:

Yep! It started when I was low on health and stamina and only went away when I relogged.

When breaking down portal conduits (mining them with a hammer or totem) will only drop the blocks about 50% of the time.
So a Portal of 6 blocks only yields 2-3 portal conduits.

1 Like

Ehhh… same as a totem/slingbow you should just be able to press ‘x’ to unequip the material


(World Builder)

y-fun-max on layered 3d nodes has some weird behavior (I think when it hits some extremes? but not entirely clear), where offsets jump straight to an altitude of 0, often affecting 2+ layers away:


the way to avoid it is to reduce the y-fun-max to a pretty low value, but it’s not entirely intuitive (and, if you want some more extreme noise between layers, you’re SOL). Though, thankfully, elevate 3d can achieve similar results as an alternative

(World Builder)

Minor one:

Layered 3d nodes seem to break the seed inheritance option for their components. E.g. if I uncheck seed inheritance on a component’s node, whenever the seed of the layered 3d node changes, the noise for the component also changes

Motivation: I want to use the same 3d function/seed for caves in a world across multiple biomes & within several custom 3d nodes (to avoid repetition).

Edit: I think this is working as intended, actually?

Edit edit: now I’m not so sure. My mental model of how I thought it worked:

^ my expectation was that both of those nodes (top row, bottom row) should evaluate to identical noise. However, they clearly do not!

Out of curiosity (@lucadeltodecso): how are seeds combined? XOR? Also, how are you converting the seed string into its numerical value (which hash func?). I’m wondering if I can reverse that and stick a static seed value on the layered 3d instance that’ll give me what I’m looking for here

It’s more than just a XOR and yes, hashed。

Cant guarantee it wont change at some poimt, but the seed combine is:

combined = childSeed ^ (seed + 0x517cc1b727220a95UL + (childSeed << 6) + (childSeed >> 2));

For parent ‘seed’ (if not inheriting parent, then it is the worldseed instead which can never ‘not’ be inherited) and there is a seperate special case that no alteration will occur to ‘seed’ at all (just passed along unadultarated) if the childSeed is exactly 0.

The nunerical seed is an FNV-1a 64 bit hash of the string seed, with a special case so that an empty string gives a 0 seed (to work with the combine special case)


Eating a shielding risotto crashes the server. Definitely for people close to me, maybe for everyone.
EDIT: seems to only be people near me, probably related to the buff message that Stretchious also saw.

I got the food buff message after will ate his risotto and then the unplayable connection message before being booted out


Something @Stretchious’ screenshot made me notice is that the badge above my head there doesn’t match with the badge on my screen for the energising effect:

1 Like

So this happened:
(Crafting time left on the Iron)

Edit: Removing all items, stopping the furnace, and closing the window fixed it.

I have the same issue from time to time. But for me it fixes itself after some time. Sometimes it takes longer and sometimes it recovers faster. (Maybe its a display error?)
Did it happen when you came back to the Furnace after some time?
Or did it happen while you stayed near it?

My wife and I were both in our base mostly afk near the furnaces the whole time.

Just tested this with about the same results. Ouch.

1 Like

Bomb mastery seems to be broken. I have 0 mastery and when using silver bombs, which require 1 mastery, it adds 1000 max stamina when it should, according to the right-click info, only add 800 seeing as my mastery is 0.

1 Like

when eating raw meat… the combat text informs me the i get 40s of the “sick” debuff but it does not show up as a debuff by the HP bar… nor does it seem to have any noticeable effects