Boundlexx UI

  • Fixes search not always working as expected since local filtering as added
  • Adds search autocomplete for Worlds, Items, and Colors
  • Adds various improvements to overall UX


great work :+1:

can you maybe add a filter to Items ->By Resource

Filter for Max World Tier [All, T7, T6, T5, T4, T3, T2, T1]

this allow us easy to find for example a World with the highest Iron Ore on max T3 World, without search in a list with a few hundred worlds for the first T3 World.

here in red i show you a example

Now that I did see this screenshot I did try search first time on another browsers because I thought search field is just placeholder.

Looks like search didn’t work with my Vivaldi browser. But after updating it did start to work :smiley:

Bug Fixes

  • Fixes some links to items that were previously 404’ing
  • Fixes reset data / purge data to be more reliable and not reset user preferences
  • Adds max width for API display for larger (>1080p) screens to help performance

New Features

  • Adds item images everywhere. NOTE: Some items are known to have missing images (like liquids, foliage, grass, mould, non-meta metamorphic variants of ore seams, etc.). I hope to get these in the nearish future whenever the upstream rendering tool is able to handle them.

  • Adds color variation section on item details

  • Adds ability to switch between Live Universe and Testing Universe of the game. This will allow you to see items from the game that are not yet released on the stable version of the game. Also gives you see all of the worlds and such from the testing universe. WARNING: The testing universe is just that, testing. Many features may not work (Atlas images) and retrieving data will be slower.

Huge thanks to @willcrutchley and his Icon Renderer to make this possible.

  • Updates images everywhere for Items, Worlds and Emojis to uses thumbnails except on the main details page for the thing. This should greatly help with loading on the item/world browse pages and reduced memory usage.
  • Updates worlds to be cached for 30 days like everything else. Now there is a periodic check every 5 minutes to retrieve worlds that have updated in the last 5 minutes and updates the local cache using that. This should great help reduce “Loading worlds…” spinners on some pages.
  • Adds item images to the Block Colors and Resources sections on the world details page.
  • Adds metal variations section to the item details page. NOTE: if you are still seeing “Color Variations” on pages for these items, you may need to reset your application data to purge the old data.

Reminder about Translations

As a reminder, I am looking for players who can natively/fluently speak English in addition to German, Spanish or French to help me translate Boundlexx UI for our foreign players! DM if you are interest in helping.


I noticed the site is currently not working:

Cause: API endpoint is having certificate issues:

1 Like

I can confirm same issue @Angellus

Sorry about that. Azure is kind of weird without hot it does SSL certs and I had to wait the full time to be able to reissue them. It is recovering now and most of the POPs (at least here in the US) have proper SSL certs again.


My apologies if this is not the right place to post this, but it seems several tabs including resources and color finder are currently down on Boundlessinfo.

I completely understand these are seperate projects. and that the problem with Boundlexx is being resolved, but is it possible these things are related? I know nothing about this stuff, but thought there may be a bigger problem with the api itself?

EDIT: Found API thread, so Boundlexx IS the source for things like Boundlessinfo and the BUTT? That makes sense. Hopefully all is back up and running soon :+1:

BoundlessInfo is mostly powered by Boundlexx. Yes. BUTT is not really powered by Boundlexx (I think maybe one page uses it, but the main shop data does not).

Also, the SSL certs finally finished being deployed to all POPs a hour or two ago so if you are still having issues with BoundlessInfo, you will need to post in the main forum post for it.

Boundless Info is all back up and running, and I’m pretty sure it has been for around eight or so hours (unless there was a temporary outage again).

If you’re still having issues with it then it must be a browser cache issue. I suggest doing a Ctrl+F5 if on PC, if mobile then clearing via the browser settings.

Browsers really shouldn’t be caching an API call though, especially not a failed one, so I can’t imagine its still afflicting you.

Edit: but apparently it is. Recommend following above steps.

I was a little surprised that there doesn’t seem to be a map overview on boundlessinfo, but I assume that’s stuff left for the devs alone to see?

Are you looking for world maps? If so, Boundlexx UI has world maps including settlement overlay and shop basket locations.
Angellus’ implementation of maps is quite good, and map interfaces can be difficult to pull off well, so I’m not surprised other apps don’t have implementations.

Once you navigate to the world, click “world atlas” and you’ll get the map.

The maps come from this thread: Boundless world maps for download

1 Like

Those links both 404 me for some reason. :oc

There is something funky going on with it, maybe try going here first:

Edit: Maybe not. Well, in the meantime you should be able to get the raw maps from the dropbox linked in James’ thread.

1 Like

I believe there is a bug with the code that tries to keep the worlds up to date. Try using the “Reset Data” button in the top right if you are getting a “Not Found” on a world.


I’ve run into a page that asks me to reset data that has always worked well. When @Ocfos mentioned 404, I checked an incognito window and got a white 404 error with “site disabled” or something similar in the message. If you want, I can PM you the actual error next time I run into it.

1 Like

That should be fixed now. There was another minor setting I missed when I migrated everything. I missed it because of those darn service workers caching everything. Haha.


I hope this is the right place for this.
I’m having problems loading Boundlexx on my pc. It was fine until a few days ago. It throws up a 504 error and I’m unable to access any of the pages.
I’m not sure if this a problem on my end or something went wrong with the site…or just maintenance maybe?
Does anyone have any info/can help?..would be greatly appreciated :hugs:

I had a hardware failure that caused some things not to load correctly. It should be resolved now.