Release 182 - Report issues here


#162

Just Jump Height I and II no Air Jump or Air Jump Height Bonus.


#163

If you hit a dirt block from the side (without breaking it), then hit the grass on top, the damage to the block is reset.


#164

I can confirm that all crafted item slots were empty. I have encountered this a few more times, and it almost seems to be a delay. If I just stare at it for long enough, it eventually rolls over an continues crafting, or finishes depending on if there are more items in the queue. It has taken anywhere from a few seconds to several minutes for a table to register that the previous item is done and the next to start. I have ten crafting tables, all of which I use regularly processing stone. This bug seems to occur randomly among them. I can’t say how often it happens, because I am usually not present while crafting marches along, it is only those times when I am actively waiting for crafting to finish, and am therefor paying close attention to the countdowns, that I catch this happening.

Yes. With some blocks I’ve noticed that the patterns bend or curve to fit the new angles seamlessly. With others there seems to be a strange disconnect.


#165

I cannot lay down/grow/plant grass onto a Beveled block of Clay. There is no indicator and the grass seed animation creates no result. I tried multiple simple-beveled blocks. It did grow on the flat block of Clay beside the problem blocks and also on chiseled sloped Clay blocks.
Grass seed has no effect…
Grass was planted on the flat block next door…


#166

We just don’t support square/bevel chiselled grass, and adding it would be a (I cannot understate this) a HuGE amount of work (grass relies on texture blending for the look, and supporting texture blends on square/bevel chiselled shapes would literally be months of mind-numbing work)


Sq and bevel chiseled blocks
#167

I did not get the feat “Days of Beacon Fuel Added” I added in enough fuel to go to 24w 20h 5m and did not get any of the feats. The beacon is on Berlyn at 1,149N and 1,115E. This is using my Atl Kal-el-crafter. I tried returning to sanctum and then going back and the feat still did not advance.


#168

Two storage cubes randomly re-oriented themselves without my direct participation. I can access them, and the items that were in them before the change are still there, but they do not link to their neighbors. Just before I noticed this, I was cutting away stone from the walls and floors nearby and replacing them with refined rock, then using the slope/bevel tools on the block directly above the storage cubes. This renovation may have triggered the change in the storage cubes’ orientation, but I didn’t see the exact moment that they moved, so I can’t say exactly what I was doing at the time. Location = Berlyn -2035N, -575E, Alt 96.


#169

Block updates seem to trigger the new texture rotation feature - reproducible in ore seams if you break one seam, the seam next to it should rotate texture.
(Unless this was fixed in 182.2)


#170

The chisel will rotate those blocks, so they may have been hit some how during your renovation


#171

Ah…my Pyramid-of-Giza type garden display will just have to rely on flat and sloped blocks then! Ty for the quick reply.


#172

I was holding a Gold Slingbow in one hand (slightly used), opened my Inventory and dragged an Iron Slingbow (from a Storage Cube) over the top of the golden one to ‘smart stack’ them. I saw the Iron one replace the Gold one completely, Goldie disappeared. The screenshot here shows the offending Iron Slingbow and the cursor is highlighting in red the location the Gold one used to be. I didn’t notice if the Iron one appeared in my character’s hand, I was too busy looking hard at my inventory wondering where my new shiny 'Bow had gone…
Golden Slingbow was replaced by Iron one instead of stacking?!
Thank you.


#173

I can confirm that my spot no longer teleports me to liquidy burny doom… Thanks!

I can reproduce easily with interface scales “Normal” and “Large”; The “small” interface scale means that the dialog window does not overlap with the skill window in full screen. If I artificially shrink the screen (windowed mode, and shrinking the window) and position it right, I can reproduce with “Small” as well.

I have not noticed any other sounds which are out of place… but then again not hearing your hammer strike breaks immersion much faster than any other missing/out of place sounds.

Hope this helps!


#174

Description: Can go through the backside of a portal using a grappling hook (and with camera dancing)

Steps:

  1. Place two portals, both with backings so that only one side is enter-able, and you can walk through.
  2. Use a grappling hook to swing through by hooking one of the top blocks

Expected: Can fly through the portal in style
Actual: Take damage from face planting into the backing and then get stuck between the two portal backing. Can escape by wiggling the camera while going through the portals.

Video: https://youtu.be/-T0RomV_3Bo


#175

Sorry, I missed this one earlier. Lets pretend that there are Basket Weaving skills I through V and I have not purchase any of them. When I mouse-over Basket Weaving I, I expect to see what effect purchasing Basket Weaving I will have on my character. When I mouse-over Basket Weaving II, I expect to see the effect which purchasing Basket Weaving II will have on my character (currently, it continues to show the effect of Basket Weaving I irrespective of which Basket Weaving skill you are mousing over) and some indication that it requires Basket Weaving I.

This means players can mouse over the attributes and plan multiple skills and multiple levels ahead… allowing them to plan more and rely less on impulse skill-purchases when trying to advance a single skill-set (like miner, or hunter) As a miner, It would be useful to know whether 3 levels of hammer mastery, or 3 levels of dex will help more; but one can only assess this if the information is available.

The cost should be external to the mouse-over as the cost is more based on “Next skill in this group” rather than the skill itself… and you don’t necessarily know the cost 2 levels down the line if other skills in that group are purchased…

This also means that if a player is deciding whether or not to use a cleanse point, they can mouse over the previous skill level to see what they’d loose.


#176

I prefer to call it a “design defect.”


#177

I wasn’t tracking the first one but was tracking the second one. I was mining gleam on Elopor. This hasn’t happened anymore after this one time.


#178

Could you list the coordinates of this particular portal so that I can take a look?

Did that also involve portals positioned over lava as well?

It looks like you have definitely hit the maximum limit for the number of friends.

After looking into it, it does occur when hitting blades of grass after hitting the soil block, but not the actual grass texture. Is this the case for you?

Thanks for the reply. We have reproduced this issue and have logged a bug. It seems that it’s more likely to occur when standing far away from machines.

From talking with the relevant dev team members, the reason for the texture changing is because the ‘tops’ and ‘bottoms’ (of which those chiselled faces belong to) are textured from above/below. If we tried changing it so that these faces retained a ‘wall’ texturing., then chiselling that same shape on the floor/ceiling would break instead.

Not been able to reproduce this, is it still happening? Were you doing anything before this? For example, did you switch characters prior to the issue occurring?

Can you also provide screenshots of the current running totals for the Home Insurance Feats as well?

I’m having a hard time imaging what this looks like. Could you provide screenshots and / or video to better illustrate this?

They won’t be part of the same smart stack, so they will simply swap over, so the Gold Spread Repeater Slingbow should now be residing in the Storage Block / Shelf. Can you check that it’s there? As it looks from the screenshot that it probably is.

Thanks for checking. It confirms that some of the Interface Scale options can cause issues with certain GUI menus.

Thanks for checking this as well. If I may ask, what’s your surround sound setup like?

Thanks for the report and video, a bug has been logged.

Thanks for the in-depth response. I’ll tag @luke-turbulenz and @olliepurkiss for them to read this.

Let us know if it starts happening again a few more times.


#179

That’s correct yes.


#180

Encountered another instance of machines freezing during process (not just a delay turning over as I previously thought it might be). I gathered all my ore and started them all in separate iron furnaces last night before bed. All five furnaces were fully repaired when I started. All but this one had finished when I logged in today.


I will leave the furnace unbroken for now, in case you want to look at it, but I’m going to remove the ingredients and shift them to a different furnace. Location of malfunctioning furnace: Berlyn, -2041N, -598E, Alt 96. Look directly north. It’s the fourth from the right, third from the left.

Edit: NVM >.< I just went back to look and it had finished the one titanium bar… Still… it took all night.


#181

I can not place a sign on a stone at one of my portals (looking at it in the picture), tried many times, but it show up on the stone for a half second and then go away.

I do not lose it, it is still in my hand.

It worked on the other side, see the picture.

Edit:
After writing this and switched back to the game it work…