Testing 162 - Report issues here


#161

Building in the prefab client puts the building restrictions on the player. Ie cool down on block placement.


#162

Coming back to the known bug when using tool, while having no SP left, causes loss of HP followed by instant healing (and there is a glitch to the right from HP/SP bars). Here is a pic to remind you:

Whatever the bug looked like, my HP levels were displayed correctly. However, since I learnt health restore skill this bug has shown yet another face: my maximum HP points are not shown properly. After working with a tool with 0 SP, HP bar would often (not always) reverse to 1200 (the starting value for a character). Working with 0SP a bit longer may or may not cause it to go back to the right level (currently I’m on 2000+ HP).

These screenshots show: 1. 1200 HP bar a while after I went down to 0 SP while mining thus activating the bug (I only noticed that after a minute or so and my SP returned to max, but HP stayed bugged); 2. Debug info confirming that my current HP is over 2000 (highlighted in yellow):


I took a dive from high to get some damage and see what happens - and my HP bar came back to normal (and correct) state:


Testing 163 - Report issues here
#163

Turning A House Into A Home doesn’t work (it’s a 2 tier builder objective). This task consists of 3 components - placing steps, walls and slabs in one’s beacon. None of them update upon placing the blocks. I tried timber and rock ones.


#164

Objective: A Prestigious Build (2nd tier for Builder).
Issues:

  1. It repeats requirements of House Proud (1st tier for Builder).
  2. Just like House Proud it doesn’t work (it’s possible to finish the task of placing 20 blocks in a beacon, but raising beacon’s prestige is not registered by the counter).
  3. After activating, it disappeared from the list of tasks under AVAILABLE bar. It was displayed top left on the screen and it was on the list of tasks under ACTIVE bar, but I couldn’t deactivate it. When I pressed “Deactivate Objective” it would disappear from the top left list on the screen for a fraction of second and pop back in then.

It kept blocking a slot in my objectives for around 2 hours. I tried again then, just before logging out, and it worked. It disappeared from my list of active objectives and appeared again on the list under AVAILABLE bar. So, it’s not a problem now, but I thought it would be worth reporting just in case.


#165

Can you clarify what you mean here? Are you having trouble placing blocks or is there a delay in doing so?


#166

@Xanotos and @LordMcCoy, thanks for the extra information, we’ve added the information to our bug database.


#167

Thanks for the information, it’s always worth reporting any objectives that are not working correctly, even if it doesn’t appear to be a problem for the time being.


#168

I am now melting iron for tool, and still get objectives where i suppose to use wood tool.
Think the wood tools objectives belong in the basic tutorial part

And the other objectives with tools should be a minimum (stone hammer or higher, copper axe or higher etc).


#169

There is a delay in placing blocks, like on the testing server. Is it expected behavior for the world builder client to do the same thing as the actual in game client?


#170

My first beacon did not show in my location list, when i used sanctum i only had the spawningpoint saved. Have to update home-location manually after a long run (my beacon show up in the compass).

Have build a workbench, filled it up with materials, but only get 2 recipes, Iron crucible and iron fire pit. Have made those 2 and place them, but no change. Have i miss something?


#171

Did you mean the actual game or the client launched from the World Builder? Are you getting the same behaviour on the game and the World Builder on the live version?


#172

Could you list the names of the affected objectives so that we can make a note of them?

Is this 1 bug or 2 bugs? Presumably it’s the latter.

Can you provide a screenshot of the Locations list? How did you update your Home location manually?

For the second, could you list the items that you have placed into the Workbench, along with any colour index information if possible? You have a smart stack in one of the slots, where it’s hard to tell whether you have a different coloured item within that smart stack.

Additionally, it could be that you might not have unlocked the necessary skills to display more recipes.


#173

Hammertime; 40 rocks mined with a wooden hammer.
Black gold: 40 rocks destroyed with a wood hammer/30 coal mined with a stone hammer.
Copperfield: 40 rocks destroyed with a wood hammer/30 copper mined with a stone hammer.

And in “Excavate to accumulate” you need to get 100 gravel with a stone hammer,.

Yes, its 2.

I click on homelocaition, then click update to get my current location as home.

Yes, equipment crafting skills is still locked…

No, only been on startplanet, no other color index, only thing i missing is that i cant see how many item in the smart stack when i mouse over it.

Now when i mouse over a smart stack it say the name of the first item (igneous rock smart stack, sedimentary rock smart stack…), which is not realy true, the stack contain different stones… Maybe rename it to only rock smart stack, and the number it contains.


#174

So the information with the coordinates and the planet below ‘Home Location’ in the screenshot was previously blank?


#175

No, it contained the spot where i first spawn in the world.


#176

The client in WB uses the current “live” client on the computer. If I am in the testing beta all the restrictions in the “live” test version is placed on the WB client. So there is a cool down on block placement when working on prefabs.


#178

Can you confirm if you’re getting the same kind of delay when placing down blocks in the normal game? Also, if you’re using Windows, can you check Task Manager if the World Builder is placing your machine under any stress when you experiencing delays when working with prefabs?


#179

Was it the Campfire or a Beacon that you placed down? It could be that it might have expired. If it’s a Beacon, you will have to add more fuel to keep it going.


#180

Beacon, yes it run out of fuel for a while.
But throwing away my homelocation seems a little harsh…


#181

Normal as in live server or test server? It happens on the test server too. If I switch out of beta the cool down goes away in the world builder client. The system is not lagging or freezing.