Testing 170 - Report issues here

Well, I’ve done a bit of experimenting:

  • I’ve uninstalled, and reinstalled. no change (still loads to where Sanctum begins to render, I get the CooCooCoo ‘bird’ sound and the portal buzz, then Boundless [testing] crashes.
  • I’ve also uninstalled and removed all the remaining files from the steam ‘boundless’ folder, then reinstalled: ditto.
  • I’ve searched Library/Application Support, and renamed anything associated with boundless I can find. no change.
  • I’ve uninstalled and re-installed the non-testing version. It loads and I can play. Checking the /tmp/tblz_log.txt though I see the same “ERROR : failed to get world data (runtimeplayerstartworld)” so I don’t think the above snippet has anything to do with the issue. So, I’m going to sent the snippet for the second, and final, error in the log.txt (I’d originally thought it was a cascade issue). But first…
  • I uninstalled and reinstalled the testing version: same crash result.

I should also mention that I now have 77Gb of 120Gb Available on Disk. Though, again, the fact that the non-test server runs should prove the issue isn’t one of disk space.

Here is the, hopefully pertinent, snippet from the log:


[2017-08-07 23:58:41] INFO : GET https://gs-testing.playboundless.com:8902/visible/use_c1_home/Kalthazar/X/X
[2017-08-07 23:58:42] ERROR : ==============================================
[2017-08-07 23:58:42] ERROR : SIGNUM: 0xb
[2017-08-07 23:58:42] ERROR : STACKTRACE: (35 frames)
[2017-08-07 23:58:42] ERROR : 000 - 0 boundless.dylib 0x00000001061217f5 _ZN9turbulenzL18CrashSignalHandlerEi + 277
[2017-08-07 23:58:42] ERROR : 001 - 1 libsystem_platform.dylib 0x00007fff9d2e8b3a _sigtramp + 26
[2017-08-07 23:58:42] ERROR : 002 - 2 ??? 0x0000000000000000 0x0 + 0
[2017-08-07 23:58:42] ERROR : 003 - 3 libGPUSupportMercury.dylib 0x00007fff9562ec98 gldModifyTexSubImage + 188
[2017-08-07 23:58:42] ERROR : 004 - 4 GLEngine 0x000000010b062e21 glTexImage2D_Exec + 2097
[2017-08-07 23:58:42] ERROR : 005 - 5 libGL.dylib 0x00007fff8bdb146d glTexImage2D + 77
[2017-08-07 23:58:42] ERROR : 006 - 6 boundless.dylib 0x00000001060f4c38 _ZN9turbulenz14graphicsdriver7Texture18GLSetDataTexture2DEjjNS_11PixelFormatEjjjPKhj + 312
[2017-08-07 23:58:42] ERROR : 007 - 7 boundless.dylib 0x00000001060f4537 _ZN9turbulenz14graphicsdriver7Texture9GLSetDataEjjjNS_11PixelFormatEbbbPKhjb + 599
[2017-08-07 23:58:42] ERROR : 008 - 8 boundless.dylib 0x00000001060f4d36 _ZN9turbulenz14graphicsdriver7Texture7SetDataERNS0_16GLGraphicsDriverEPKhjb + 198
[2017-08-07 23:58:42] ERROR : 009 - 9 boundless.dylib 0x00000001060d5bdc _ZN9turbulenz7Texture7SetDataEPNS_14GraphicsDeviceEPKhj + 172
[2017-08-07 23:58:42] ERROR : 010 - 10 boundless.dylib 0x0000000105f13d35 _ZN9turbulenz9boundless8renderer14VolumetricData21Invalidated4Handler2DEv + 117
[2017-08-07 23:58:42] ERROR : 011 - 11 boundless.dylib 0x0000000105f1361a ZN9turbulenz9boundless8renderer14VolumetricData10UpdateDataEjRNSt3__15arrayIiLm6EEEPdiiiNS3_8functionIFvRKNS0_5ChunkEiiiiEEENS8_IFvvEEENS8_IFvSB_iiEEESF + 906
[2017-08-07 23:58:42] ERROR : 012 - 12 boundless.dylib 0x0000000105f12b10 _ZN9turbulenz9boundless8renderer14VolumetricData6UpdateERKNS0_12PortalCameraE + 864
[2017-08-07 23:58:42] ERROR : 013 - 13 boundless.dylib 0x000000010575f98f _ZN9turbulenz9boundless11GameManager10RenderMainERKNSt3__16vectorIPKNS0_8renderer16PortalRenderDataENS2_9allocatorIS7_EEEERKNS3_IPKNS4_20PlotBeaconRenderDataENS8_ISF_EEEE + 543
[2017-08-07 23:58:42] ERROR : 014 - 14 boundless.dylib 0x0000000105760a41 _ZN9turbulenz9boundless11GameManager6RenderEv + 1857
[2017-08-07 23:58:42] ERROR : 015 - 15 boundless.dylib 0x00000001056324d3 _ZN9turbulenz9boundless11Application6RenderEv + 259
[2017-08-07 23:58:42] ERROR : 016 - 16 boundless.dylib 0x000000010564212c _ZN9turbulenz9boundless11Application13MainStateLoopEv + 652
[2017-08-07 23:58:42] ERROR : 017 - 17 boundless.dylib 0x0000000106113372 _ZN9turbulenz7RunLoop4TickEv + 146
[2017-08-07 23:58:42] ERROR : 018 - 18 boundless.dylib 0x00000001060ce432 _ZN9turbulenz8Platform4TickEv + 34
[2017-08-07 23:58:42] ERROR : 019 - 19 boundless.dylib 0x00000001060a5522 _ZN9turbulenz15ApplicationBase4TickEPy + 210
[2017-08-07 23:58:42] ERROR : 020 - 20 boundless.dylib 0x00000001060a8753 -[NativeEntryView animate:] + 99
[2017-08-07 23:58:42] ERROR : 021 - 21 Foundation 0x00007fff893ece0f __NSFireTimer + 83
[2017-08-07 23:58:42] ERROR : 022 - 22 CoreFoundation 0x00007fff87962c54 CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION + 20
[2017-08-07 23:58:42] ERROR : 023 - 23 CoreFoundation 0x00007fff879628df __CFRunLoopDoTimer + 1071
[2017-08-07 23:58:42] ERROR : 024 - 24 CoreFoundation 0x00007fff8796243a __CFRunLoopDoTimers + 298
[2017-08-07 23:58:42] ERROR : 025 - 25 CoreFoundation 0x00007fff87959b81 __CFRunLoopRun + 2065
[2017-08-07 23:58:42] ERROR : 026 - 26 CoreFoundation 0x00007fff87959114 CFRunLoopRunSpecific + 420
[2017-08-07 23:58:42] ERROR : 027 - 27 HIToolbox 0x00007fff86eb9ebc RunCurrentEventLoopInMode + 240
[2017-08-07 23:58:42] ERROR : 028 - 28 HIToolbox 0x00007fff86eb9cf1 ReceiveNextEventCommon + 432
[2017-08-07 23:58:42] ERROR : 029 - 29 HIToolbox 0x00007fff86eb9b26 _BlockUntilNextEventMatchingListInModeWithFilter + 71
[2017-08-07 23:58:42] ERROR : 030 - 30 AppKit 0x00007fff85452a54 _DPSNextEvent + 1120
[2017-08-07 23:58:42] ERROR : 031 - 31 AppKit 0x00007fff85bce7ee -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 2796
[2017-08-07 23:58:42] ERROR : 032 - 32 AppKit 0x00007fff854473db -[NSApplication run] + 926
[2017-08-07 23:58:42] ERROR : 033 - 33 AppKit 0x00007fff85411e0e NSApplicationMain + 1237
[2017-08-07 23:58:42] ERROR : 034 - 34 libdyld.dylib 0x00007fff9d0d9235 start + 1
[2017-08-07 23:58:42] ERROR : ==============================================

That bug has been fixed locally and should be in the next update. There was an issue in the OpenGL backend creating textures with mipmaps in some cases when it shouldn’t have been, and the Mac OpenGL drivers are a bit too strict at times in not so helpful ways… (like this crash, instead of a nice error).

Ok. Thanks.
To update: I just checked and found the update available; Downloaded, and ran using the [testing] version. Oddly after warping in from Sanctum I showed at the coords of my Home on the non-test Solum (empty of course). However, my skills and inventory seemed off too.

I travelled to my Test home location, and gone. Nothing there.

It looks like you wiped the test servers again? sigh. Upon double checking, I found my test inventory, skills, and objectives are all the same as the non-test character.

So I’ve lost everything I had there. I can’t say it was entirely unexpected. I figured it would happen sometime, but I never finished the build and hadn’t a chance to say goodbye… ;(

I’m also a bit jealous of the builds that stay though (or the folks with so much free time they can re-build entirely in a few days)…

Imma put 5coin on it being a very special type of scone eaten at teatime on alternate Tuesdays in unpronounceable towns ending with Shire.

Or perhaps a gentleman’s hat.

I’m a new user and I bought and downloaded Boundless on steam. The game does not show up in my hard drive. Every time I try to run the game from steam it crashes, I pulled up the crash logs and found the evidence there. I’ve uninstalled and reinstalled several times, turned off the anitvirus, updated the drivers on my video card, and uninstalled and reinstalled steam. Nothing has worked for me. The graphics card is a 750 TI and I have an i5 processor. 16 gigs of ram as well. plz halp

Help me @lucadeltodecso, you’re our only hope!

1 Like

Can you share your game log… it might help to narrow down the issue.

At which point does the game crash? During start up, or in game?

Can you make sure that all the dependencies are installed correctly:

hello hello
i am trying to do stuff on the testing server but i get a unstable connection every time
i already tried everything i can fro my side …no diffrence can you help?

Turns out you called it, @james. He was missing dependencies. Computer he is on has run Boundless before, but had the drives formatted when we sold it to him. All squared away and @taylorparks1375 is online and loving the game now!


Well there could be multiple reasons why your are experiencing a slow internet connection:

  • Slow connection, the game has high bandwidth requirements. What connection speed do you have? If I remember correctly the game required 24 mbit down.
  • High latency between your PC and the server where the planet is running on. (For example, as EU player playing on Australian servers can cause delays and lagg).
  • Or maybe your compter is slow or software on it is causing your traffic to delay / lagg.

Running through the starter objective chain, and got to the point of creating and placing my first beacon. When I broke my campfire to place the beacon in its place, the objectives reset to build a campfire. I’m now stuck waiting on enough xp to level up so I can spend a skillpoint to continue progressing.


This seems to also have reset the games recognition of gaining basic crafting recipes, since I’m unable to cook anything in the stone furnace I’ve built. Since I had already leveled up a few times and had 4/5 core skills unlocked, I have to gain another level to get the last cleansing point to reset my skills back to the beginning and retake them.


Well that didn’t work. I can’t cook anything because it says I lack basic crafting recipes. Is this referring to something other than the basic crafting recipes that are the first core skill unlocked?

The furnace saying that you lack basic crafting recipes is a known bug. It is meant to display other messages. You get this message when:

  • Not enough fuel is provided.
  • The recipe requires two ingredient but you only provided one of them.

Players most commonly stumbles upon this when they provide just one soft coal as fuel or when they are trying to make glue (requires sap+bones)

1 Like

Still get the Unstable Connection way to often to play comfortably and without worrying about it.

To summarize, I sometimes need to press ‘esc’ 3-5 times before I can finally get my mouse’s pointer to press on quit and confirm before the game breaking message cuts off all menus.

Perhaps, but I’ve got furnaces that aren’t making anything now, and it’s like a viral disease. Right now I only have one functioning furnace, and when I make new ones they don’t work, either. I have plenty of fuel, I know how to make glue, but I’m getting the “lack basic crafting recipes” despite having made plenty of glue previous. I think there’s another bug here.

I meant to reply to @NiSiSuinegEht in my post.

Anyway, looking at the screenshot NiSi posted. Wood isn’t a valid fuel source for furnaces, is it?

Other items, such as leaves, are flagged as Invalid when I try to put them in the fuel slot, but it lets me put wood in. I’ve found some coal seams, but I can’t even damage them with stone tools. Is this another bug, or do I need higher tier tools that I can’t craft yet?

You can mine soft coal seams with stone hammer, for coal seams you need to get a copper hammer.

Ah, thanks! I hadn’t seen that information on any wikis. It would be nice if there was some kind of in-game harvestability indicator.

Found some soft coal, mined it, and am cooking up some starberries. Thanks for the help!

Yeah, I know you were–I was just trying to get this out there as a reinforcement of the defect.

Ii other news, I think wood was added as fuel for something–beacons?–during this release.

On Live, at least, wood is a valid fuel, but you need 5 Trunks to cook a berry:

– not that it tells you so! :smiley: