World Builder Cube Caves Acting Abnormally

While working on some biomes I noticed that I seem to have accidentally saved something that was causing a whole lot of biomes to become more or less “corrupted” with some 3d noise. I tried seeing what I had saved and changing it back but was unsuccessful. I made back-ups of my stuff and then uninstalled Boundless and deleted the “boundless” folder in my documents folder. Upon reinstalling the documents folder repopulated but whenever I try to launch world builder now the program instantly crashes.

Happy to provide any additional details you may need.

Try moving the World Builder configs out of your Documents folder.

Next time you start they will be reset to the defaults.

Then try gradually re-adding any different configs.

This should help isolate which config is causing the crash.

Is there anything in the world builder log?

That worked and the program launches now. Still having some issues though. I think the problem with with the 3d noise node for tier 3 caves. Via the inverted cave view:

It goes all the way up to the surface and REALLY messes with some biomes. For example, tier_swamp_forest:

Similar issues with Tier 4 caves it looks like. But Tier 5 seems fine. Just confirmed by adding Tier 5 caves to some of the Tier 3 biomes and had no issues come up.

Happy to add a log if you still need it but I’m guessing since it’s launching fine now you might not.

I tried to go messing with the newly created caves to see if I could fix this. I’m going to start this explanation with my second step and go back to the first.

I opened up the tier_3_caves 3d noise node and removed, at random, “flat caves” over on the right. When doing the chunk visualization I get very similar to the above.

However, the first step I did was to remove cube caves.

And things look amazingly better.


However, there’s one small problem…there’s no caves at all. Here’s the chunk visualization with inverted cave view on.

Why did the random noise node skip everything even when cube isn’t an option and why is it forcing the selection of cube when cube is an option?

I think the answers to these questions will help me with whatever is going on because right now this is happening to all T3 and T4 pre-built biomes.

Is this just a non-issue and it won’t always be like this if I use these biomes for a local world? AKA the random noise will actually be random upon world generation and just doesn’t play nicely with the visualization tool?

If you want to stop caves bursting through into the surface, then you need to stop the noise function from creating noise based on altitude. I think there are some cave functions that do this, where it’s blending with an altitude function.

Cave functions are quite difficult to control because you kind of want them underground, but also in mountains, so above “ground”. So below and above? Hmm.

So then you would blend the altitude blend with a horizontal noise, so that the caves can sometimes burst through the surface.

As I said, cave functions are possibly the hardest to balance.

1 Like

I’m just surprised because this is with the standard world builder files. I’ve had some success in using layering for 3d noises and just adding thing “constant” layers around the altitude my biome’s real heightmap starts. Takes away the chance of finding a natural cave mouth or some such but feels better than some of the images above.

Appreciate your time James, I’ll go ahead and replace the caves with my own noise for the tier 3+4 biomes I may want to use. Thank you!

It does feel something’s not quite right in addition to cave noises being tough to balance. The default biomes are having so many cave issues compared to the images I took and shared here:

For example, current castle_mountains:

castle_mountains from that post:

Both are the default biome from World Builder. I made no changes to either.

@Heureka I’m sorry to be tagging you so much recently but are you also having issues with biomes being filled with many many caves that come up and break the surface?

It looks like the setting “caveSurfaceShrink” not working as it was before.
It use to keep caves underground when turned off, but sometimes it remove the whole cavesystem instead.

I noticed that sometimes i have to turn it on to see my caves, but then they break the surface instead…

The 3D node “cave_height_3d” is often better to use as the last node, where you can set the height of the cavesystem and also use the heightmap to distribute the caves.

It is mostly an try and error with a mix of both.

And my castle_mountain looks good, like the old pic above.

What is that setting? I’m not finding it anywhere.

The cave_height_3d worked well for the main heightmap area but whatever’s going on is still causing the ground and rivers to become pure cube cave area.

I get that caves are trial and error but outside of the above image I’m not actually trying anything. I just want to be able to get back to the default biomes from the image I took before, the one that you said is working for you. I did a fresh reinstall so I have brand new files so I’d like to know why mine does not look like yours…not something I need you to answer per se. I’m just wondering if a change was made to world builder and was inadvertently pushed out.

I do not know why Your look different…

If You want i can send You mine and test it.

Here is the caveSurfaceShrink:

Here are a shot from cave-setting in my castlecastle.

Are those the defaults?

Here’s what I’m getting now after a fresh install. Y goes from 0 for the tier_3_caves to 256 for the constant.


Switching the tier_3_caves out for simple caves helps immensely though! Thanks!

1 Like

Yes, it is the default.

The Y in the layer node tell where the selected wave should centre, so in your picture you got the wave-noise at altitude 0 and the constant at altitude 255.