Game Won't Start :-(

Tags: #<Tag:0x00007fa0d125c168>

When I go to start the game, the white window flashes up for a second, then nothing.

  • Ryzen 9 5900X
  • RX 6900 XT
  • 32GB Ram
  • Latest Win 10
  • Latest BIOS (but one)

Checking graphics drivers now.

@GreyArt247 has a similar set-up (on two PCs) and both unable to play BL now.

2 Likes

Cheers, @majorvex, yeah, I noticed that thread. (nice hunt video, btw!)

I’ve tried playing with numerous settings in the AMD control panel and nothing makes a jot of difference.

At least @GreyArt247 can get the game running! :exploding_head:

I don’t have any mods running, either, fwiw.

I’m not angry at anyone, in particular … but not being able to run the game is not really that good … especially since it seems to run OK on the old Intel UHD 620 laptop.

EDIT - OK, there’s some stuff in the Event Viewer:

Faulting application name: boundless.exe, version: 1.19.39.0, time stamp: 0x6011a2ea
Faulting module name: ucrtbase.dll, version: 10.0.18362.1110, time stamp: 0xb4cacc38
Exception code: 0xc0000409
Fault offset: 0x000000000006c408
Faulting process ID: 0x1ee0
Faulting application start time: 0x01d792f97776f73a
Faulting application path: P:\SteamLibrary\steamapps\common\Boundless\boundless.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report ID: 41fed0e6-3c3a-4fbe-9248-a2a595a29bf4
Faulting package full name: 
Faulting package-relative application ID: 

Some rando on a Windows thread said that clearing an “AutomaticDestinations” folder could resolve it, but I don’t have any recent items as they’re completely disabled on my system.

They do also mention it could be GPU related. :weary:

I’ve been trying to help them troubleshoot, as much as possible. It could be a driver issue from a recent update. My last suggestion was to right click on the windows icon > device manager > display drivers > and right click on your GPU - uninstall. Install the last version that worked: https://www.amd.com/en/support/previous-drivers/graphics/amd-radeon-6000-series/amd-radeon-6900-series/amd-radeon-rx-6900-xt

I assume you’ve verified files via Steam and everything already.

1 Like

Oh aye, yeah, all verified, etc.

I’ll try rolling back to an older driver, although … I’m pretty sure that it didn’t work on the older driver, either. :weary:

I’ll try a full re-install tomorrow, but if it’s related to a file that’s not part of the install, it could be problematic.

I was all happy that I’d got this PC back (there were power cut outs from a BIOS issue that is running rife through AMD setups), and it appears to not be triggering that issue … now I can’t run Boundless in pretty mode. :sob:

EDIT - To confirm, the drivers had not been updated at the start of this thread (I can’t remember the version) but it didn’t work then (whilst it had done just a month ago) … I’ve updated them, and it still doesn’t work.

Current version 21.8.1.

I’m wondering if the BIOS updates from AMD have changed frequencies, etc, so much that it’s actually making the game unable to start … could that even be a thing?

I did notice their memory clock speed was low & core clock seemed really high. It looked like an attempt to overclock or do a performance tune-up, but they said they hadn’t altered those settings. Like some weird bios changes or settings. I guess there could have been a wonky update somewhere that threw things off. Do you use Wattman?

1 Like

Cheers :+1:

But, nah, I run everything at stock. :man_shrugging:

That was most of the reason for going 5900X and RX 6900 XT … I shouldn’t need to change anything, y’know?

Memory is clocked at 3200, which is stock, and the GPU is seated correctly (had to double check it as it wasn’t running at 16x … reseated … all good).

I’ll reinstall tomorrow, and see what’s up. Too late for all that gubbins today.

Running an SFC scan now.

@GreyArt247, ye of the Sochaltin I brotherhood … can you check your Event Viewer after a failed startup for me, pwettyy pweeaaaase?

EDIT - SFC scan was fine. tried to register the file (regsvr32 ucrtbase.dll) with this error:

Also (I’ll update the original post with this), I have just updated Windows … TODAY.

It worked before the update, and now it doesn’t. You see, this is why I don’t update Windows. :angry:

I’m going to see if I can download the file from Microsoft … as I tried to

1 Like

Both of you might want to run the event viewer log and have someone look at it to pinpoint your issue, after your game crashes. Could be ram, could be a lot of things.

1 Like

Cheers, yeah, I don’t think it’s RAM, or anything like that. The machine has just come back from SCAN and they’ve been stress testing it for weeks now due to the aforementioned AMD issues.

Need Grey to check his events … I have a feeling this is Windows Update related, and if so will end up affecting more than just us two.

Just grabbing Boundless logs now, will update with them shortly … but here’s the log.txt:

[2021-08-16 23:50:18.130] [INFO]  C:\Users\autobuild\.jenkins\workspace\boundless-win64-deploy\native\src\browserfeatures\filecache.cpp:169 (turbulenz::FileCache::Initialize) Cache dir: C:\Users\mmm\AppData\Local\Turbulenz\boundless\static-cache\
[2021-08-16 23:50:18.130] [INFO]  C:\Users\autobuild\.jenkins\workspace\boundless-win64-deploy\native\src\appbase\standaloneplatformreaders.cpp:645 (turbulenz::StandalonePlatform::SetHttpCachePath) HttpCache: enabled (C:\Users\mmm\AppData\Local\Turbulenz\boundless\static-cache)
[2021-08-16 23:50:18.210] [INFO]  C:\Users\autobuild\.jenkins\workspace\boundless-win64-deploy\native\src\core\tzprocess.cpp:148 (turbulenz::sMinidumpCallback) Process crashed and minidump was written to C:\Users\mmm\AppData\Local\Turbulenz\Boundless\tblz_crashdump__9efc7116-07b5-483b-981d-cce4d55363cf.mdmp

Have also tried running the game on beta/testing mode, too. :slight_smile:

1 Like

This guy was also getting the Faulting module path: C:\WINDOWS\System32\ucrtbase.dll error. Said it turned out to be the Windows audio service.

It looks like a lot of people are having a similar problem and this fix worked for them too.

“I got family involved (a programmer/developer)! Thought it might be audio related from a crash-dump, and turns out it is a crash caused by the Windows Audio service. I ran services.msc as Admin, scrolled down to the Windows Audio service, stopped it, started NMS, then it would load up! After the initial selection menu, I tabbed out and started the Windows Audio service again and the sound came on, and I can now play again.”

3 Likes

Cheers, I did notice windows installing some new thing which I investigated, a surround audio thing (that I don’t need) … lemme see if I searched for it in non-private.

A-Volute

:thinking:

EDIT - PPS … before I started it today it did a game update. Currently on App ID 324510 (I think that’s just the Steam ID), and Build ID 6147980. Updated Aug 17 2020 12:45 AM.

1 Like

I tried this, but it had no effect, however I’ve not restarted since I tried a couple of other tweaks.

I also stopped all Nahamic services and processes, too. I’ll try it with the Realtek HD Audio blah next. I’ll also try disabling that at boot.

I will uninstall Boundless now, do a full restart, and try again.

Have re-installed. It didn’t start before the restart … I will try … er … afterwards.

I will also see what analogues to this file my laptop has.

OK, @majorvex, looks like simply restarting after a re-install did the trick. Perhaps Windows refreshed that file as a part of the install, I dunno.

I’m not seeing the error when it starts.

It did, however, start with the popup all-white window, then that quickly changed to a black/grey window … and then closed again, as if it were crashing. :sweat: … However a few seconds later the little white window returned … then it maximised to full screen, and Boundless loaded.

Going to play with some AMD settings to see if I can pimp it even more than it already is, then apply mods, etc. But it all looks good. Please do close ( after @GreyArt247 has finished responding, of course :wink: ).

1 Like

Sorry @MadManMoon, didn’t mean to cause any agro …

I was wondering if this is relevant in your event viewer.

Did a quick google and was wondering if any info here could help

https://ugetfix.com/ask/how-to-fix-ucrtbase-dll-application-error-on-windows/

Edit: Good to see you got it sorted :smiley:

2 Likes